Commit 074481b2 authored by Mark Olesen's avatar Mark Olesen

CONFIG: updates for kahip and scotch

parent a856a5fc
......@@ -400,7 +400,7 @@ you may have additional hurdles to using the newest versions of clang.
| [openmpi][page openmpi] | [download][link openmpi]. The newer [openmpi][newer openmpi] make exhibit stability issues.
| [adios][page adios] | [repo][repo adios] or [github download][link adios] or [alt download][altlink adios]
| [scotch, ptscotch][page scotch] | [download][link scotch] or [older][older scotch]
| [kahip][page kahip] | [download][link kahip] or [newer][newer kahip]
| [kahip][page kahip] | [download][link kahip] or [older][older kahip]
| [metis][page metis] | [download][link metis]
......@@ -499,11 +499,11 @@ easier to use `grep` and find the relevant pages and links.
[page scotch]: https://www.labri.fr/perso/pelegrin/scotch/
[older scotch]: https://gforge.inria.fr/frs/download.php/file/37622/scotch_6.0.6.tar.gz
[link scotch]: https://gforge.inria.fr/frs/download.php/file/38040/scotch_6.0.7.tar.gz
[link scotch]: https://gforge.inria.fr/frs/download.php/file/38114/scotch_6.0.8.tar.gz
[page kahip]: http://algo2.iti.kit.edu/documents/kahip/
[link kahip]: http://algo2.iti.kit.edu/schulz/software_releases/KaHIP_2.00.tar.gz
[newer kahip]: http://algo2.iti.kit.edu/schulz/software_releases/KaHIP_2.10.tar.gz
[older kahip]: http://algo2.iti.kit.edu/schulz/software_releases/KaHIP_2.00.tar.gz
[link kahip]: http://algo2.iti.kit.edu/schulz/software_releases/KaHIP_2.12.tar.gz
[page metis]: http://glaros.dtc.umn.edu/gkhome/metis/metis/overview
[link metis]: http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/metis-5.1.0.tar.gz
......
Short summary of third-party software versions for recent OpenFOAM versions.
OpenFOAM-1912
---------------
scotch_6.0.8 *minor*
kahip-2.12 *update*
OpenFOAM-1906
---------------
......
......@@ -76,6 +76,7 @@ usage()
Usage: ${0##*/} [OPTION] [lib|libso] [kahip-VERSION]
options:
-gcc Force use of gcc/g++
-cmake PATH With cmake from the given path
-help
* Compile KaHIP
......@@ -85,6 +86,7 @@ USAGE
exit 1
}
#------------------------------------------------------------------------------
exportCompiler minimal # Minimal compiler info for CMake/configure
# Parse options
while [ "$#" -gt 0 ]
......@@ -94,6 +96,12 @@ do
-h | -help) usage ;;
-gcc) useGcc ;;
-cmake)
[ "$#" -ge 2 ] || die "'$1' option requires an argument"
CMAKE_PATH="${2%%/}"
shift
;;
lib|libso)
targetType="$1"
;;
......@@ -159,9 +167,20 @@ install()
$incdir
}
echo "Starting build: $kahipPACKAGE ($targetType)"
echo
# Newer KAHIP (>= 2.11) uses CMake,
# but unfortunately does not install include/
# nor pass through flags for 64bit indices in the header.
withCmake=true
version=$(echo "$kahipPACKAGE" | sed -e 's/^kahip[-_]*//i')
case "$version" in 2.0*) unset withCmake;; esac
if true
then
(
echo "Starting build: $kahipPACKAGE ($targetType) using wmake"
echo
cd $KAHIP_SOURCE_DIR/lib || exit 1
export GIT_DIR=$KAHIP_SOURCE_DIR/.git # Mask seeing our own git-repo
......@@ -172,7 +191,7 @@ echo
cpMakeFiles kahip 2>/dev/null
if [ -e ../interface -a ! -e interface ]
if [ -e ../interface ] && [ ! -e interface ]
then
ln -s ../interface interface
fi
......@@ -194,6 +213,6 @@ echo
echo "Error building: kahip"
exit 1
}
fi
#------------------------------------------------------------------------------
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment