Commit 0f5e1d67 authored by mark's avatar mark
Browse files

ENH: initial support for building ParaView with QT5

- still issues with the required version
  eg, system has qt-5.5, but ParaView tries to use qt-5.6
parent ed0c6388
...@@ -307,23 +307,31 @@ addQtSupport() ...@@ -307,23 +307,31 @@ addQtSupport()
# parse -> "Using Qt version X.Y.Z in ..." # parse -> "Using Qt version X.Y.Z in ..."
QtVersion=$($qmake -query QT_VERSION) QtVersion=$($qmake -query QT_VERSION)
# Split Major.Minor.Revision - could also use IFS hacking case "$QtVersion" in
set -- $(echo "$QtVersion" | sed -e 's/\./ /g') 3.* | 4.[0-4]*)
# QT is too old
QtMajor=$1 cat <<ERROR
QtMinor=$2 ----
Error: ${0##*/}
if [ $QtMajor -lt 4 -o $QtMajor -eq 4 -a $QtMinor -lt 5 ]
then QT version ($QtVersion) provided < 4.5
echo "*** Error: Qt version provided < 4.5" Please use the -qmake option to specify the location of a newer QT version
echo "*** Please use the -qmake option to specify the location of a version of Qt >= 4.5" For example,
echo "*** e.g." ... -qmake /usr/local/qt-4.6.2/bin/qmake
echo "*** -qmake /usr/local/qt-4.6.2/bin/qmake" ... -qmake $installBASE/qt-4.6.2/bin/qmake
echo "*** -qmake $installBASE/qt-4.6.2/bin/qmake" ----
ERROR
exit 1 exit 1
fi ;;
5.*)
# QT4 is the default, must specify QT5 explicitly
addCMakeVariable "PARAVIEW_QT_VERSION:STRING=5"
;;
esac
else else
echo "*** Error: cannot find qmake either at \$QMAKE_PATH or in current \$PATH" echo "Error: cannot find qmake either at \$QMAKE_PATH or in current \$PATH"
echo
exit 1 exit 1
fi fi
} }
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment