Commit 231733bc authored by Mark Olesen's avatar Mark Olesen

STYLE: use foamEtcFile with -config option instead of config.sh/

parent 5ecf33d4
......@@ -29,7 +29,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
#------------------------------------------------------------------------------
# ADIOS version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/ADIOS
_foamEtc -config ADIOS
adiosPACKAGE=${adios_version:-adios-none}
......
......@@ -34,7 +34,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
#------------------------------------------------------------------------------
# libccmio version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/ccmio
_foamEtc -config ccmio
ccmioPACKAGE=${ccmio_version:-libccmio-2.6.1}
targetType=lib # Default is static linkage
......
......@@ -64,8 +64,8 @@ unset BOOST_ARCH_PATH CGAL_ARCH_PATH GMP_ARCH_PATH MPFR_ARCH_PATH # Purge old
# CGAL, boost and gmp/mpfr versions from OpenFOAM etc/config.sh files.
# Get compiler first and let CGAL config override GMP and MPFR
_foamEtc config.sh/compiler
_foamEtc config.sh/CGAL
_foamEtc -config compiler
_foamEtc -config CGAL
boostPACKAGE=${boost_version:-boost-system}
gmpPACKAGE=${gmp_version:-gmp-system}
......
......@@ -44,7 +44,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
#------------------------------------------------------------------------------
# FFTW version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/FFTW
_foamEtc -config FFTW
fftwPACKAGE=${fftw_version:-fftw-system}
......
......@@ -45,7 +45,7 @@ unset GMP_ARCH_PATH MPFR_ARCH_PATH # Purge old
WM_COMPILER_TYPE=ThirdParty # Ensure we get the correct settings
# Default GCC, mpfr, gmp and mpc versions from OpenFOAM etc/config.sh file:
_foamEtc config.sh/compiler
_foamEtc -config compiler
gmpPACKAGE=${gmp_version:-gmp-system}
mpfrPACKAGE=${mpfr_version:-mpfr-system}
......
......@@ -29,7 +29,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
#------------------------------------------------------------------------------
# Gperftools version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/gperftools
_foamEtc -config gperftools
gperftoolsPACKAGE=${gperftools_version:-gperftools-system}
......
......@@ -58,7 +58,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
}
. etc/tools/ThirdPartyFunctions
#------------------------------------------------------------------------------
_foamEtc config.sh/kahip
_foamEtc -config kahip
kahipPACKAGE=${KAHIP_VERSION:-kahip-system}
targetType=libso
......
......@@ -50,7 +50,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
WM_COMPILER_TYPE=ThirdParty # Ensure we get the correct settings
# LLVM/Clang version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/compiler
_foamEtc -config compiler
llvmPACKAGE=$clang_version
......
......@@ -58,7 +58,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
}
. etc/tools/ThirdPartyFunctions
#------------------------------------------------------------------------------
_foamEtc config.sh/metis
_foamEtc -config metis
metisPACKAGE=${METIS_VERSION:-metis-system}
targetType=libso
......
......@@ -30,7 +30,7 @@ wmakeCheckPwd "$WM_THIRD_PARTY_DIR" || {
#------------------------------------------------------------------------------
# mgridgen version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/mgridgen
_foamEtc -config mgridgen
mgridgenPACKAGE=${MGRIDGEN_VERSION:-mgridgen-none}
......
......@@ -55,7 +55,7 @@ _foamAddPath() { true; }
WM_MPLIB=MPICH # Ensure we get the correct MPI
# mpich version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/mpi
_foamEtc -config mpi
mpiPACKAGE=${FOAM_MPI:-mpich-system}
......
......@@ -37,7 +37,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
unset vtk_version mesa_version # Purge current values
# mesa version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/vtk
_foamEtc -config vtk
mesaPACKAGE=$mesa_version
......
......@@ -55,7 +55,7 @@ _foamAddPath() { true; }
WM_MPLIB=OPENMPI # Ensure we get the correct MPI
# openmpi version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/mpi
_foamEtc -config mpi
mpiPACKAGE=${FOAM_MPI:-openmpi-system}
......
......@@ -34,7 +34,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
#------------------------------------------------------------------------------
# Boost version (headers only) from OpenFOAM etc/config.sh file:
_foamEtc config.sh/CGAL
_foamEtc -config CGAL
boostPACKAGE=${boost_version:-boost-system}
tecioPACKAGE=tecio
......
......@@ -40,7 +40,7 @@ cd ${0%/*} && wmakeCheckPwd "$WM_THIRD_PARTY_DIR" 2>/dev/null || {
unset vtk_version mesa_version # Purge current values
# vtk version from OpenFOAM etc/config.sh file:
_foamEtc config.sh/vtk
_foamEtc -config vtk
VTK_VERSION="${vtk_version##*-}" # Without prefix
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment