Commit 41d1059a authored by Henry's avatar Henry
Browse files

ParaViewFunctions: Updated Qt version check

Resolves bug-report http://www.openfoam.org/mantisbt/view.php?id=1088
parent b353c99c
......@@ -325,10 +325,10 @@ addQtSupport()
QtMajor=$1
QtMinor=$2
if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4 && $QtMinor -lt 5) ]]
then
echo "*** Error: Qt version provided < 4.5"
echo "*** Please use the -qmake option to specify the location of a version of Qt >= 4.3 "
echo "*** Please use the -qmake option to specify the location of a version of Qt >= 4.5 "
echo "*** e.g."
echo "*** -qmake /usr/local/qt-4.6.2/bin/qmake"
echo "*** -qmake $installBASE/qt-4.6.2/bin/qmake"
......
......@@ -325,10 +325,10 @@ addQtSupport()
QtMajor=$1
QtMinor=$2
if [ $QtMajor -lt 4 -o $QtMinor -lt 5 ]
if [[ ($QtMajor -lt 4) || ($QtMajor -eq 4 && $QtMinor -lt 5) ]]
then
echo "*** Error: Qt version provided < 4.5"
echo "*** Please use the -qmake option to specify the location of a version of Qt >= 4.3 "
echo "*** Please use the -qmake option to specify the location of a version of Qt >= 4.5 "
echo "*** e.g."
echo "*** -qmake /usr/local/qt-4.6.2/bin/qmake"
echo "*** -qmake $installBASE/qt-4.6.2/bin/qmake"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment