Commit aa2523ee authored by Mark Olesen's avatar Mark Olesen

DOC: update BUILD and SOURCES information

parent 6e03e1ec
......@@ -450,7 +450,8 @@ The minimum CMake requirements for building various components.
2.8.12.2 llvm-3.7.0
2.8.12.2 llvm-3.8.0
2.8.4 cmake-3.6.0
3.3 ParaView-5.6.0
3.3 ParaView-5.6.3
3.10 ParaView-5.7.0 - ParaView-5.8.0
3.4.3 llvm-3.9.1
3.4.3 llvm-4.0.0 - llvm-6.0.0
3.6 ADIOS2
......
......@@ -2,36 +2,44 @@
For building some particular third-party libraries from source,
the normal [OpenFOAM System Requirements][link openfoam-require]
will be insufficient.
may not be sufficient.
This is most notably the case for ParaView and/or QT compilation.
As duly noted in [BUILD][link third-build] and [README][link third-readme] and information,
As duly noted in [BUILD][link third-build] and [README][link third-readme] information,
building ParaView from source tends to be the most difficult part of
any third-party compilation.
For general functionality, the paraview version distributed with
the operating system or a [binary package][download ParaView]
may be sufficient for your needs.
is likely adequate for your needs.
**Please help us with keeping the information here up-to-date and accurate.**
***Please help us with keeping the information here up-to-date and accurate.***
### Ubuntu
Dependencies:
The full dependency list for building ParaView can be
found from the corresponding [debian/control](https://salsa.debian.org/science-team/paraview/-/blob/master/debian/control)
file.
The following subset may be enough:
```
sudo apt-get install qt4-dev-tools libqt4-dev libqt4-opengl-dev freeglut3-dev libqtwebkit-dev libxt-dev
sudo apt install cmake qt5base-dev qttools5-dev qttools5-dev-tools libqt5opengl5-dev libqt5x11extras5-dev libxt-dev
```
### openSUSE
Dependencies:
### openSUSE
The full dependency list for building ParaView can be
found from the corresponding [rpm spec](https://build.opensuse.org/package/view_file/science/paraview/paraview.spec)
file.
The following subset may be enough:
```
sudo zypper install glu-devel
sudo zypper install libQtWebKit-devel libqt4-devel qt4-assistant-adp-devel qt4-x11-tools
sudo zypper install Mesa-libEGL-devel
sudo zypper install libqt5-qtbase-devel libqt5-qtsvg-devel libqt5-qttools-devel libqt5-qtx11extras
sudo zypper install libXt-devel
```
<!-- Quick links -->
[download ParaView]: https://www.paraview.org/download/
......
Short summary of third-party software versions for recent OpenFOAM versions.
Third-party software versions for recent OpenFOAM versions
OpenFOAM-2006
---------------
ADIOS-2.4.0
CGAL-4.12.2 *update*
ParaView-5.6.3
boost_1_66_0 *update*
fftw-3.3.7
openmpi-4.0.3 *update*
scotch_6.0.9
kahip-2.12
OpenFOAM-1912
---------------
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment