Commit 03075ef0 authored by Mark Olesen's avatar Mark Olesen
Browse files

STYLE: update some build comments regarding min gcc for clang

parent 6485db81
...@@ -297,8 +297,12 @@ install the 32-bit development libraries by default. ...@@ -297,8 +297,12 @@ install the 32-bit development libraries by default.
The minimum version of clang required is 3.3. The minimum version of clang required is 3.3.
*Attention*: If you are building a newer version of clang, you may need to *Attention*: If you are building a newer version of clang, you may need to
update your CMake beforehand. update your CMake beforehand since GNU *configure* can only be used prior
GNU *configure* can only be used prior to clang version 3.9. to clang version 3.9.
If your system gcc is particularly old
(see [minimum gcc requirements for clang](#min-gcc))
you may have additional hurdles to using the newest versions of clang.
| Name | Location | Name | Location
...@@ -365,6 +369,10 @@ The minimum gcc/g++ requirements for building various components. ...@@ -365,6 +369,10 @@ The minimum gcc/g++ requirements for building various components.
4.7 llvm-3.5.2 4.7 llvm-3.5.2
4.4 llvm-3.4.2 4.4 llvm-3.4.2
If your system gcc/g++ is too old to build the desired llvm/clang
version, you may need to build a lower llvm/clang version and then use
that clang compiler for building the newer llvm/clang version.
<!-- gcc-related --> <!-- gcc-related -->
[page gcc]: http://gcc.gnu.org/releases.html [page gcc]: http://gcc.gnu.org/releases.html
...@@ -457,6 +465,7 @@ The minimum gcc/g++ requirements for building various components. ...@@ -457,6 +465,7 @@ The minimum gcc/g++ requirements for building various components.
[link AddOns]: https://develop.openfoam.com/Community/OpenFOAM-addOns [link AddOns]: https://develop.openfoam.com/Community/OpenFOAM-addOns
[link community-projects]: http://www.openfoam.com/community/projects.php [link community-projects]: http://www.openfoam.com/community/projects.php
---
<!-- Standard Footer --> <!-- Standard Footer -->
## Additional OpenFOAM Links ## Additional OpenFOAM Links
......
...@@ -72,6 +72,7 @@ More details can be found the ThirdParty BUILD.md information. ...@@ -72,6 +72,7 @@ More details can be found the ThirdParty BUILD.md information.
[link AddOns]: https://develop.openfoam.com/Community/OpenFOAM-addOns [link AddOns]: https://develop.openfoam.com/Community/OpenFOAM-addOns
[link community-projects]: http://www.openfoam.com/community/projects.php [link community-projects]: http://www.openfoam.com/community/projects.php
---
<!-- Standard Footer --> <!-- Standard Footer -->
## Additional OpenFOAM Links ## Additional OpenFOAM Links
......
...@@ -49,7 +49,7 @@ openmpi-1.10.0 *update* ...@@ -49,7 +49,7 @@ openmpi-1.10.0 *update*
scotch_6.0.3 scotch_6.0.3
OpenFOAM-v2.4+ OpenFOAM-v2.4
--------------- ---------------
CGAL-4.6 *update* CGAL-4.6 *update*
ParaView-4.1.0 ParaView-4.1.0
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment