Commit d814bce3 authored by Mark Olesen's avatar Mark Olesen
Browse files

CONFIG: adjust paraview lib path for 5.5 (issue #793)

  ParaView 5.4 and older:
    - requires lib/paraview-X.X only

  ParaView 5.5:
    - requires lib/
    - does not appear to require lib/paraview-X.X, but retained for simplicity

- Change default version to paraview-5.5.0 for testing purposes
parent 6d8be522
......@@ -36,10 +36,15 @@
# setenv LD_LIBRARY_PATH ${ParaView_DIR}/lib/paraview-5.4:${LD_LIBRARY_PATH}
# unsetenv ParaView_VERSION # avoid using ThirdParty settings
#
# In newer versions (paraview 5.5), the contents of the lib/ changed
# and now need to include that as well:
#
# setenv LD_LIBRARY_PATH ${ParaView_DIR}/lib:${ParaView_DIR}/lib/paraview-5.5:${LD_LIBRARY_PATH}
#
#------------------------------------------------------------------------------
# USER EDITABLE PART: Changes made here may be lost with the next upgrade
setenv ParaView_VERSION 5.4.1
setenv ParaView_VERSION 5.5.0
set ParaView_QT=qt-system
set cmake_version=cmake-system
......@@ -127,8 +132,10 @@ if ( $?ParaView_VERSION ) then
endif
endif
# Prepend paraview libraries
setenv LD_LIBRARY_PATH "${pvLibDir}:${LD_LIBRARY_PATH}"
# Prepend paraview libraries.
# ParaView 5.4 and earlier - requires lib/paraview-X.X only
# ParaView 5.5 - requires lib/
setenv LD_LIBRARY_PATH "${ParaView_DIR}/lib:${pvLibDir}:${LD_LIBRARY_PATH}"
if ($?FOAM_VERBOSE && $?prompt) then
echo "Using paraview"
......
......@@ -36,13 +36,18 @@
# export LD_LIBRARY_PATH=$ParaView_DIR/lib/paraview-5.4:$LD_LIBRARY_PATH
# unset ParaView_VERSION # avoid using ThirdParty settings
#
# In newer versions (paraview 5.5), the contents of the lib/ changed
# and now need to include that as well:
#
# export LD_LIBRARY_PATH=$ParaView_DIR/lib:$ParaView_DIR/lib/paraview-5.5:$LD_LIBRARY_PATH
#
# Note
# When _foamAddLib is unset (eg, called from makeParaView or from foamPV):
# - the ParaView_VERSION variable is retained.
#------------------------------------------------------------------------------
# USER EDITABLE PART: Changes made here may be lost with the next upgrade
ParaView_VERSION=5.4.1
ParaView_VERSION=5.5.0
ParaView_QT=qt-system
cmake_version=cmake-system
......@@ -132,8 +137,10 @@ then
done
fi
# Prepend paraview libraries
export LD_LIBRARY_PATH=$pvLibDir:$LD_LIBRARY_PATH
# Prepend paraview libraries.
# ParaView 5.4 and earlier - requires lib/paraview-X.X only
# ParaView 5.5 - requires lib/
export LD_LIBRARY_PATH=$ParaView_DIR/lib:$pvLibDir:$LD_LIBRARY_PATH
# Add in python libraries if required
if [ -r $pvPython ]
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment